google pixel

  • Government Workers Are Being Ordered to Update Their Google Pixel Phones ASAP

    Government Workers Are Being Ordered to Update Their Google Pixel Phones ASAP

    As originally reported by Forbes, due to a high-severity vulnerability, Google has warned federal employees to update their Pixel devices before 4th July, or else they should stop using the device. This warning—CVE-2024-32896—is a part of the Known Exploited Vulnerabilities (KEV) catalog managed by CISA (Cybersecurity and Infrastructure Security Agency). While Google has not discussed…